I2C Gigablue HD800UE

Discussion in 'Other satellite receivers.' started by gaga24, Mar 22, 2016.

  1. gaga24

    gaga24 New Member Staff Member

    Messages:
    1
    Likes Received:
    3
    Trophy Points:
    3
    Gender:
    Male
    Gigablue HD800.png

    With this tutorial you can unbrick Gigablue HD800UE
    In my case, Gigablue HD800UE was flashed with wrong bootlader, box is showing only red light.
    This tutorial is extension to existing JTAG for Gigablue 800 and SE
    Thanky JB for assistance and support.

    Let get started:

    I2C (JTAG) Gigablue HD800UE

    1. Check your box PSU, measure 12V, make sure that is working properly
    2. AC Power off the STB.
    3. Get Cypressboard from ebay: CY7C68013A-56 EZ-USB FX2LP
    4. Yo will need old PC or laptop with XP 32bit

    5. Connect Cypresboard to PC, install drivers and use drivers from /CypressUSBdriver_XP folder
    I did try original Cypressboard drivers with XP, Win10, and nothing worked, so save your time and use this drivers.

    6. Now, connect your Cypressboard and box. I use old PC front panel usb cabels with pins.
    I2C on your box moherboard is right of processor cooler. At first connect, GND, SDA, SLC wires only. Connect VCC wire only if you try everything and still cannot get connection.
    In my case, 3 wire (wihout VCC) was ok. See picture 002-003.jpg

    7. Install BBS tools from folder /Broadband Studio 3+Bcm97325 using setup.exe file
    8. Go to folder / GB800UE memory offset and copy MXIC MX29GA320EL.xml to C:\Program Files\Broadcom\Broadband Studio 3\Flashes
    Overwrite if needed. Remember this file name, you will need to select this later.
    Gigable SE and UE have the same MX29GA320EL70G chip, same moherboard, same hardvare, only display is different, so this file is taken from SE box.

    9. Box PSU is off, turn on Cypressboard mini swich, red light on Cypressboard is on
    10. Start Broadband Studio 3, go to devices, select Bcm97325, dont forget to setup your I2C Cypressboard to use USB connection istead LPT.

    11. Now, powerup your box, you should get Connected green status in Broadband Studio 004.jpg

    12. Use flash explorer, select MXIC MX29GA320EL.xml, click refresh, and select browse, go to folder /CFE bootloader and select cfe.bin
    cfe.bin is latest for Gigablue 800UE, dont use another and dont edit offset. Click start and wait while flash is in progress. In my case 1 minute. 005.jpg

    13. Power off STB, disconnect cables, power on box. Flash bootloader using USB method, flash image using USB method. 007.jpg


    http://www.mediafire.com/download/94rbycyuif46dvp/GB+800ue.zip
     

    Attached Files:

    samiherz, orbitasat and Johnny B. like this.
  2. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    I bring this post back in sight because I had received an email from someone who has this Gigablue HD800UE receiver with this problem.
     
  3. orbitasat

    orbitasat New Member

    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Gender:
    Male
    Hi, JB please can you give-me a help? I´ve a giga blue UE+ and it stops the internet modem, so for during some time I did put a wireless pen and it did works, but few days ago it did stops works with wireless pen too, and I did try other pens, and din´t work, so can you give-me an idéia how to fix the internet modem in it?, because box it was working nice and I´m sure the problem is only from net modem.

    thanks so much for your help.
     
  4. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    It depends a bit if it's due a hardware issue, thinking of some bad sectors on the nand flash chip or when it's related to the 5v usb sector.
    In any case, see if it helps to use a usb hub, one with his own power source.
    When it not helps, then it could be a issue with the motherboard, thinking of some bad voltage from a dc to dc chip.

    However, I do not have these box, and therefore I can not give you any information about the voltages.
     
  5. emmiko

    emmiko New Member

    Messages:
    10
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    hi gaga24
    i successful connection bbs by Broadband Studio 3
    but flash Explorer not have my stb flansh model
    ST M29W128GSH70ZS6
    can you help me create a xml file ?
     
    Last edited: Oct 8, 2019
  6. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    I'm not sure if he can help you with it but to give you some reply to your issue,
    I've checked all my (nand flash) programmers and none of them support this M29W128GS
    The closest I get is the M29W128GH and M29W128GL thus it seems to be a uncommon flash chip.
    Also, finding the datasheet for it is at least in my case not found, only some sellers.

    I think, the most easiest method to attempt to solve this issue is to replace the nand flash chip to the chip that is support in this topic.
     
    raza05 likes this.
  7. raza05

    raza05 Active Member

    Messages:
    139
    Likes Received:
    219
    Trophy Points:
    43
    Gender:
    Male
    if you are asking about the same dvb you asked
    https://jb8a8f8.com/support/index.php?threads/a-new-stb-with-bcm7325-jtag-interface.495/
    then you must contact the manufacture first as these are custom made boxes build for specific transmission as I have mentioned earlier it 'll be better if you explain in detail how it reached to this position
     
    Johnny B. likes this.