Duo stuck on "starting"

Discussion in 'VuPlus Duo Hardware troubles and Repair support.' started by Jules, Jun 7, 2018.

  1. Jules

    Jules Active Member

    Messages:
    124
    Likes Received:
    26
    Trophy Points:
    28
    Gender:
    Male
    Hi Guys,
    After sorting a couple of boxes with the Buck supply mod and valuble help from Johnny B and Fingers, I have obtained another faulty Duo.
    This one is stuck on starting, but when try to load firmware, according to display it sees the USB drive but does nothing else. Not sure of the history, when I try to put a bootloader on also nothing happens.
    I am thinking should I try loading new firmwaref from RS232? But haven't got the utilty program.

    Hope you Guys can give me some pointers?
    Thank you.
    Regards,
    Jules.
     
  2. Jules

    Jules Active Member

    Messages:
    124
    Likes Received:
    26
    Trophy Points:
    28
    Gender:
    Male
    Hi again, quick update.
    After leaving for about 10 mins, went back to it and firmware was loaded successfully.
    Seems what was thowing me was it just said "start USB" but it seems it was actually reading.
    Now I have the common problem just stuck on "starting". Not sure if this is a clone or not ( no white label on top).
    Do you think it is time to try the buck reg mode please?
     
  3. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,547
    Likes Received:
    1,316
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    If you already have replaced the famous cap, then better is to create a Jtag/I2c connection to the board and to upload the boot loader.
    The reason why it failed after the usb upgrade may have to do with a bad nand chip or wrong uploaded image file.
    A duo clone has always a security chip on-board, a original duo has also a sort of chip, but this is a smd sot23-5 ic instead of a Syncmos/Stm chip.
     
  4. Jules

    Jules Active Member

    Messages:
    124
    Likes Received:
    26
    Trophy Points:
    28
    Gender:
    Male
    Thanks Johnny,
    Have you got a diagram for Jtag please?
    I haven't changed the famous cap yet, beacause I was getting "starting" in the display. Do you think it could still be that cap then even though it's not just the red LED on it's own?
     
  5. tomeek.p

    tomeek.p Member

    Messages:
    75
    Likes Received:
    3
    Trophy Points:
    8
    Gender:
    Male
    Replace this capcitor.
     
  6. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,547
    Likes Received:
    1,316
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    To rule out that it is happening through the familiar cap, it is always better to replace it before you start thinking about other things.
    However, I did not immediately saw that you are experiencing this problem with a Duo2, and that is a completely different box than the duo.

    Similarly the solutions such as jtag, this is not (as far as I know) possible with the Duo2 due to the non-existent cpu software/drivers for the bbs.
    So also the question of whether it is a clone, or an original box, as far as I know there are never clones of the vuduo2 made, more thinking than the icloud ibox version, which looks completely different.

    Your problem may still be related to a cap problem, but it is not possible to say which one.

    Personally, I would find the solution to flash this box again via the USB and or via the serial way.
    Maybe this forum topic from vuplus-images.co.uk helps you on your way.
     
  7. Jules

    Jules Active Member

    Messages:
    124
    Likes Received:
    26
    Trophy Points:
    28
    Gender:
    Male
    Thanks, It is the Duo 1 I'm talking about.
    Will change the cap 807 and report back.
     
  8. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,547
    Likes Received:
    1,316
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Okay in that case I have moved this topic to the duo instead of the duo2.

    As for the cap replacement, normally it's a 220uF cap, you may also use a higher cap as for example a 330uF or 480uF and better is to keep the cap voltage between the 10v till 50v.

    Place the cap in the correct position, it has a plus/minus side.
    Vu+_duo_C807.jpg

    As for jtag, see this drawing, use only the Sda/Scl/Gnd connections to the jtag board.

    [​IMG]

    If you have also used the Jtag Vcc pin then there is the risk that the inductor F808 may become defective, this should then be measured as if it were a fuse.

    [​IMG]
     
  9. Jules

    Jules Active Member

    Messages:
    124
    Likes Received:
    26
    Trophy Points:
    28
    Gender:
    Male
    Hi Guys,
    Thanks.
    Changed 807 and it's working. I can avoid doing the Buck reg mod for now!
    Many thanks again.
    Cheers, Jules.
     
    Johnny B. likes this.
  10. Jules

    Jules Active Member

    Messages:
    124
    Likes Received:
    26
    Trophy Points:
    28
    Gender:
    Male
    Thanks for the Jtag info also, will keep for future ref.