Dm900 repair, Content-Type: text / html; charset = utf-8 problem etc..

Discussion in 'Hardware troubles and Repair support.' started by Johnny B., Nov 4, 2020.

  1. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,269
    Likes Received:
    1,026
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    My repair story, a bit much to read but could be helpful to someone else with this problem.

    In a weird way my box quit after I turned it off during startup.

    My symptoms were ..
    1. It gave a white exclamation mark at first, then green later.

    2. It automatically went into rescue mode, got an ip too, but couldn't use the browser.
    Note: sometimes it did not get a ip, but when I plugged in a usb stick is then often does.
    Whatever computer, and web browser version I tried, it always gave the known,
    Content-Type: text / html; charset = utf-8 problem so this was not an option to get it right, and the ftp also refused.

    dm900-utf-8-issue.jpg

    What works...
    Only the service usb port worked, and it was also accessible via Telnet, so these were possibly the only options to try and fix the problem.

    I tried everything I could find on the internet, that seemed to look similar like this error, but most came to the conclusion that it could hardware issue, it could be a damaged nand flash chip problem because the serial terminal output show the error mmcblk0, which was only readable or locked.

    In any case, I first tried the BOLT mode method.
    This can be reached in the serial terminal Bps 9600, and by pressing the CTRL/C buttons and turning on the box so you can get into BOLT mode which gives you the possibility to flash the rescue-dm900.bin file via usb with the following command.

    BOLT> show devices
    BOLT> dir usbdisk0
    BOLT> boot usbdisk0:/rescue-dm900.bin
    Notes that the rescue-dm900.bin file must be present on the usb stick.

    That worked, at least the process was executed and after a while it stated in the terminal screen that it was ready, but this gave no improvement in my case, the same problem remained.

    Still, I had the feeling that it could only be solved via the rescue method, and didn't really feel that it was a hardware error.
    In any case, I wanted to try everything before replacing the nand flash chip.

    So then via telnet, and the online rescue flash method ..
    putty-dm900-wgetsnap.jpg
    As you can see, everything went well but unfortunately, no good result, the (Putty) com port output still gave these problems.

    Click pic when you like to see it fully
    Snap1.jpg

    After trying a few more things, without any result, I was about to give up, and the last idea to replace the nand flash chip was not really an easy job because these chips are soldered with solder balls.

    By chance, and the solution ..
    By coincidence I still had my serial connection (Putty terminal) active, and somehow decided to start up the board without the front panel was connected.

    And some kind of miracle (at least not expected at all) happened, the whole receiver came back to life, as if nothing was wrong.
    Everything works, including the tuner, etc., and only because the front panel was not connected.:confused:

    I thought it was a badly connected flat cable but when I plugged in the front panel again I got the old error back, so my logic was that there must be a hardware problem with the front panel.

    Front panel investigation...
    Whatever I measured, there was nothing on the front panel that was faulty, and there is not much electronics on the front panel, so I didn't really understand.

    So I was thinking about rescue mode again, but how, I no longer had a front button!
    Now of course I could have done the to-the-rescue command via Putty / Telnet to get into this mode, but as far as I know only works with the original OpenDreambox image file, and OpenAtv, and this box has OpenPli installed.

    dm900-to-the-rescue-opendreambox.jpg

    Openpli does not know this command, at least not the version I had, so that was not possible to do.
    dm900-telnet-to-the-rescue-openpli.jpg

    Okay, because the box works without the front panel, and it had little electronics, I came up with the idea to just disconnect the display as you can see here,

    Click pic when you like to see it fully
    dm900-Unlock-disconnect-display.jpg

    After I disconnected only the (oled) display, and reconnected the front panel itself, the box still worked, and I was able to use the front push button to enter the rescue mode, and I luckly get the normal rescue screen, so I was able to do the Online recovery and thus get the OpenDreambox image file installed, and after it then execute the update-rescue -v command via serial mode.

    The end is in sight ....:rolleyes:
    After this update it was time to see if the display could be connected without the box falling back into the old error, and indeed .... it just worked again.:)

    dm900-repaired.jpg

    Finally, I did solve it, possibly in a strange way, but with this box this was the only way to bring it back to life so that it can do everything you may expect it to do.

    In any case, I was lucky to be able to solve it without it being a hardware problem as previously thought, but it was one of my most rare and odd repair I ever had experienced.

    So in short...
    When you can access the rescue mode by a browser, but you only get a white screen with the message Content-Type: text / html; charset = utf-8 on it.

    Then it may be help to disconnect the display from the front panel and try it again by the front push button way and see if you get the normal rescue screen in your browser.

    Or, disconnect the front panel and use Putty in telnet mode and type the to-the-rescue to get to the rescue screen.
     
  2. toysoft

    toysoft Well-Known Member Staff Member

    Messages:
    376
    Likes Received:
    459
    Trophy Points:
    63
    Gender:
    Male
    Location:
    Switzerland
    Home Page:
    Great experience and fix !

    TS
     
    Aliraza63 and Johnny B. like this.