DM900 Dead LAN

Discussion in 'Hardware troubles and Repair support.' started by The Hitman, Aug 18, 2021.

  1. The Hitman

    The Hitman New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    Hello
    I have a DM900 UHD and it looks like LAN port got fried while on vacation even tough box power was off, but lan cable stayed inside, so i guess thats how. I guess my options are to change CPU or go wifi with a USB stick. I have some PLI image on it that hardly has any Wifi drivers or even a wirelesslan plugin. Im trying to flash another image trough the service miniusb. Drivers are installed, it recognizes the port but i cant find the right tool. Any suggestions? Optishaher tool dont want to do the job, is it coz if payment ? Thanks
     
    Melgas likes this.
  2. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,586
    Likes Received:
    1,350
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Since there is a working openpli system on it , that is if I have read it correctly, than it seems to me the easiest way to download and add the wifi drivers to it with the usb port.
    But Toysoft may help you better with it I think.
     
    raza05 likes this.
  3. The Hitman

    The Hitman New Member

    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    Gender:
    Male
    I tried that. I even found a 10 year old wifi usb stick that it detects, but when i want to configure the wifi network i get the message "wirelesslan plugin is missing", so i searched for an ipk package for PLI for enigma2-system-wirelesslan.ipk and most of what i find failed to install. Only one did but didnt changed anything.
     
  4. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,586
    Likes Received:
    1,350
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Yes, I see what you mean, I did some testing with different usb/wifi sticks and despite the packet manager having installed the drivers,
    Snap4.jpg

    it always ends with the, The wireless LAN plugin is not installed.
    Snap2.jpg

    This is happening as far as I can see from openpli 7 and up.
    The usb chipsets I tested included the 8188su v1 which always worked without installing drivers on all versions of dreamboxes, but now they seems only to support the 8188eu chipset.
    I've also tested the original wifi rt3070L dreambox module from the dm800se and about 4 other brands.
    They refuse all with openpli v7 and above, they all gives the same issue.

    Openatv and the original stock dreambox software give no problems, so to me it seems that there is something wrong with the openpli 7 and higher versions, or they support only a few chipsets.
    In any case, I've tested several openpli versions, as these,
    Snap5.jpg

    I think that Toysoft may know more about this, as for me it ends here as for testing it.
     
    raza05 likes this.
  5. Aliraza63

    Aliraza63 Active Member

    Messages:
    110
    Likes Received:
    192
    Trophy Points:
    43
    Gender:
    Male
    Which Wifi stick u have now ?
    share the pic and info
     
    raza05 and Johnny B. like this.
  6. toysoft

    toysoft Well-Known Member Staff Member

    Messages:
    439
    Likes Received:
    543
    Trophy Points:
    93
    Gender:
    Male
    Location:
    Switzerland
    Home Page: