DM8K - "ERROR" displayed in LCD after Flash update

Discussion in 'Hardware troubles and Repair support.' started by wrangles, Jun 15, 2017.

  1. wrangles

    wrangles New Member

    Messages:
    5
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    Hello all,

    I'm new to the forum and was wondering if anyone could help me with a problem thats arisen after flashing what appears to be a bad clone image?

    My 8K is a clone box and I have the original Ferrari SIM along with a newer Japhar sim. I have two of these boxes in total and generally very happy with their performance - the new Japhar sim and associated images have breathed new life into them.
    A couple of days ago, I was "experimenting" with different images (old and new) and installed an image that I downloaded from another forum. Upon reboot, the LCD on the 8K displayed "ERROR"with the Dream logo in the background. Despite trying numerous procedures suggested by other 8K owners, I have not been able to overcome this issue in order to flash a working image. I have tried the SIM from my second 8K box with no success and have also proven that the SIM from the broken box is working perfectly so the issue appears to reside on the mainboard.

    I've tried the null modem with ethernet cable solution but to no avail. The system is recognized by the Japhar flasher version of DreamUP however it does not transfer the bootloader. It just sits with the following in the console:
    20:51:06 box type: DM8000
    20:51:06 Enabled recovery of bad sectors

    I've also tried optiflasher 2 but this returns an error "DM8000 detected" and then " Wrong boot response". I'm about to give up at this stage but thought I'd ask the knowledgeable folk on this site if they had any ideas?

    edit: I should also add that I don't get any activity lights on the Ethernet port since the failed flash operation.


    thanks in advance for any help you can give.


    Wrangles.
     
    toysoft likes this.
  2. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    819
    Likes Received:
    106
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Only the Error on the display...
    Hmmm, I had such a case years ago and may have some notes from it in my work shop which I could check tomorrow in the evening.

    In any case it's wise to connect the rs232 serial service port to a computer and to see with a terminal as Putty or windows hyperterminal if you get some output from the box.
    And for uploading attempts regarding the boot loader and software it's better to do it with a windows Xp system and using both ports, the rs232 service port and network port.
     
  3. wrangles

    wrangles New Member

    Messages:
    5
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male

    Thanks Johnny. Your help is very much appreciated! I'll wait for your review of your notes over the next day or two.

    In the meantime, I've connected via hyperterm and putty on an XP machine with a 9 pin serial port and get the following:-

    BCM97400
    AB
    001A168C
    1s
    Sync=0
    LLMB=0
    L2=0
    RAC_I=0
    RAC_D=0

    Copy Code...34TUCV

    (c) 2007,2008 Dream Multimedia GmbH. All rights reserved.
    Dreambox DM8000
    FIRST STAGE 1.00 {BO23}
    Second stage loader wasn't found. Don't panic - it's not a (real) problem.
    You don't need to repair your Dreambox. It just means that the flashrom with
    the graphical menu was erased. You can restore this with a tool like DreamUp
    with serial access.
    RESCUE{012}
    MICRO2ND OK, build #60d (20080519)
    FP version 7 detected

    Any ideas? The issue appears to be the second stage as per the message above but I've no idea how to load this when DreamUp and the other utilities dont appear to be working in this scenario.

    Thanks

    Wrangles.
     
    Last edited: Jun 15, 2017
    toysoft likes this.
  4. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    819
    Likes Received:
    106
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Based on.. MICRO2ND OK, build #60d (20080519)
    I'm thinking of a bad nand flash chip, or wrong data on it.

    However normally it should be fixable by only using the serial port.
    If the upload refuses with the serial port, that it could be possible that the serial chip has some issues and needs to be replaced for a new one.
    Since you have two boxes, you could consider to replace the rs232 module from the working one to the defective box to see if you are be able to upload the software with only using the serial port.
    But be sure that you place it correct on the motherboard pins otherwise you could risk to damage the good one.
     
    wrangles and toysoft like this.
  5. toysoft

    toysoft Member Staff Member

    Messages:
    40
    Likes Received:
    34
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Switzerland
    Home Page:
    The issue I can see here is a bad bootloader loaded into the box, so probably JapharFlasher could fix the box, as it accepts any sim card with it's bootloader. The RS232 port works, as you done a log, so its a very good news.

    Remember that if you use the JapharFlasher/Dreamup you MUST have both cables, RS232 (connected to your PC to a REAL Rs232) AND RJ45 (connected to a router).

    For me your problem is only bad data loaded (the image is definitely corrupted) in your box.

    Also the ERROR message is appearing with the Sim card doesn't give the right data to the Bootloader/SSL, this would mean here that in fact the SIMs are OK, but the bootloader loaded into your box is CORRUPTED.

    TS
     
    Johnny B. likes this.
  6. toysoft

    toysoft Member Staff Member

    Messages:
    40
    Likes Received:
    34
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Switzerland
    Home Page:
    P.S.: I don't think that loading a corrupted image will destroy physically a Flash chip... but definitely the data in it is corrupted.
     
    Johnny B. likes this.
  7. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    819
    Likes Received:
    106
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    @toysoft
    Hi friend, good evening, but one remark about the rs232 port.. ;)

    That it receive data says nothing of the serial chip, Tx may work, but the Rx part may be detective.
     
    toysoft likes this.
  8. wrangles

    wrangles New Member

    Messages:
    5
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male


    Johnny B, Toysoft,

    I changed over the RS232 card between the DM8K's and fired up Japhar Flasher. Immediately after hitting the connect button, the loader started to download to the 8k and has let me flash an image to the box which now appears to be working perfectly. Thanks so much to both of you for helping me get this sorted - I was about to give up on this receiver and to transfer the japhar sim to my old 800se. Now I have three working receivers once again and its all due to your help and direction!

    Hopefully someone else can also benefit from this fix.

    Thanks so much once again.


    Wrangles
     
    toysoft likes this.
  9. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    819
    Likes Received:
    106
    Trophy Points:
    43
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Ah, that is good news.
    Lucky that you had the possibility to swap the rs232 modules.
    And if you have plans to fix the defective one, I have here a nice howto for it.
    rs232-serial-port-chip-replacement.

    Anyways congrats with fixing it. :)
     
    wrangles and toysoft like this.
  10. toysoft

    toysoft Member Staff Member

    Messages:
    40
    Likes Received:
    34
    Trophy Points:
    18
    Gender:
    Male
    Location:
    Switzerland
    Home Page:
    So definitely Johnny you hit exactly the failure that the box had, not due to the bad image, and that stopped him from flashing it. It's good that this is fixed, he should now get the RS232 chip replaced as that chip is extremly important for restoration of the box ;o).

    I am happy the box flies again, and it has a nice Japhar sim in it ;o)

    TS

     
    Johnny B. and wrangles like this.
  11. wrangles

    wrangles New Member

    Messages:
    5
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male

    Thanks for sending this Johnny. I'll have a go at replacing the faulty chip over the next few days..
     
    toysoft likes this.
  12. wrangles

    wrangles New Member

    Messages:
    5
    Likes Received:
    5
    Trophy Points:
    3
    Gender:
    Male
    I'll be sticking to the tried and tested Japhar images from this point onwards ;-).
     
    toysoft likes this.