Cloud Ibox 4 update image

Discussion in 'Cloud-Ibox4 receiver' started by rubeneo, Jul 7, 2023.

  1. rubeneo

    rubeneo New Member

    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    3
    Gender:
    Male
    Hello, I have a cloud ibox 4 that appears at startup with the magic box logo, I am trying to install a new image, but it does not load the usb, I have downloaded several images but there is no way, the file says vuplus, but I don't know if it's vuplus or you have to put magicbox...

    IMG_4988.jpg IMG_4989.jpg
     
  2. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Have you also tried theā€¦
    OpenPLI 4 Cloud Ibox 4 (Mini Duo) Backup By Ferret
    It's an old one, but good for testing.

    Anyways, u need a clone image file for these box, an original will not work without the VuJ chip/board modification.
    And if that fails to upload, there might be a problem with the usb port, try the front and back usb ports, maybe one of them will fail.
     
    raza05 and rubeneo like this.
  3. rubeneo

    rubeneo New Member

    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    3
    Gender:
    Male
    Thank you, if I have tried that image and the same thing continues to happen, in all usb ports. The usb ports work, since they are detected and files are recorded on them
     
  4. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    If you have a computer nearby, and have at least a db9 rs232 to Usb cable you can usually see through a terminals program like Putty in serial mode if it is actually trying to read from the usb, and why it is being rejected.

    Another option is, maybe use a USB hub with its own power source and see if it will work.
    In that case it is a weak USB voltage supply from the receiver.

    Another option is, to re-upload the cfe bootloader, I'm not sure because the one I still have was modded with the vuJ chip and used the vu+ duo original cfe file for it, as also the image files.

    Another possibility may be that the nand chip needs to be replaced.
    That is quite doable with some experience, but to bring it back to life the jtag/i2c process must also do it, and for that you must have at least an i2c cypress board interface.
     
    raza05 likes this.
  5. rubeneo

    rubeneo New Member

    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    3
    Gender:
    Male
    The cloud ibox 4 works, but I don't like the image it has, it has bugs.
    I don't have usb to rs232, sore usb with power supply, do you mean an external hard drive?
     
  6. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Just a USB hub with external power supply so it doesn't use the receiver's 5v when plugging in a USB stick.
    For example something as these,
    Snap29.jpg

    It's just a thought why it doesn't read from your USB stick.
    What can also help is to use an old usb stick, something like a 128mb stick or a 4gb may also.
     
    raza05 and rubeneo like this.
  7. rubeneo

    rubeneo New Member

    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    3
    Gender:
    Male
    I have tried with memories of 1gb, 4gb... and it does not work. it could be that the name of the folders was not correct

    file:
    vuplus/duo:
    -------------------------------
    BackupSuite.log
    imageversion
    kernel_cfe_auto.bin
    root_cfe_auto.jffs2
    --------------------------------
     
  8. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Seems correct to me, the files in the folder vuplus\duo\

    Furthermore, I have pretty much given all the tips, I always check via an RS232 terminal why it does not want to read from USB.

    Maybe it's because of the magic box bootloader, maybe it uses a different folder and software, but I don't know.
    I converted mine to work with the original vuduo bootloader/image files, and it still works.
    But it costs money, and whether it is still worth it for this box is up to the person to decide.

    Otherwise you are dependent on the latest old software that is released for this box, as Ferret indicated/replied in one of your posts.
     
    raza05 and rubeneo like this.
  9. rubeneo

    rubeneo New Member

    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    3
    Gender:
    Male
    I've read Ferret threads, I think the box is really a magixbox mg2, that's why the files don't work, I can't find any image for that box
     
  10. Johnny B.

    Johnny B. Technical Support Staff Member Moderator

    Messages:
    2,840
    Likes Received:
    1,518
    Trophy Points:
    113
    Gender:
    Male
    Location:
    Netherlands
    Home Page:
    Maybe you have seen this old post from a member westbank (digitalworldz.co.uk) if not than it is interesting to read, someone who seems to have the same problem as you. It's old and as far as I can see with no solutions, but it may indeed indicate it's not a hardware issue.
     
    rubeneo and raza05 like this.
  11. rubeneo

    rubeneo New Member

    Messages:
    27
    Likes Received:
    8
    Trophy Points:
    3
    Gender:
    Male
    Thanks Johnny
     
    Johnny B. likes this.